Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Launch Base Beta Test
For all those involved in the beta test of Launch Base, I have PM'd you a link to the download.
Please post any problems/bugs/questions/etc here, or PM me.

EDIT: [2008-08-04]
The beta test is now public. Please note that the DCoder DLL is still in production so only pre-compiled mods will work 100%.
The Launch Base setup program can be downloaded from

Please post any problems/questions in this topic.

EDIT: [2008-08-24]
Launch Base files are now stored on STX so you need to re-download manually so that the links are updated:
Ever wondered what the hell is going on?
Believe me friend you're not the only one.

Check out Launch Base for RA2/YR -
Also home to the Purple Alert mod, 1.002 UMP, and the YR Playlist Manager.
Bug: Setup allows you to deselect everything (including the base marked as "required") and continues installation, even asking you if you want to run Launch Base now. Doesn't create a folder or anything, though.
Problem: No one is gonna read the large-ass disclaimer at the beginning. Trimming it down to key points for the stupid is advisable.
Problem: Downloading/updating something (Playlist manager in my case) and then cancelling the second setup does not remove or mark the now-useless setup.
Problem: Now Launch Base is gone after doing
Bug: Playlist manager turns up in menu even though setup was cancelled - trying to run it results in Run-time error '53': File not found. Clicking OK on the message box closes Launch Base with no further warning or message.
Problem: There is no obvious uninstall button.
Problem: Was asked twice if I wanted to deinstall, only to get the message that uninstall was not successful, there are reisidual files.
Problem: After doing right-click -> uninstall, I can now do right-click -> delete.
Problem: Playlist manager is not in the list of available tools anymore, and I have no idea how to get it back.
Bug: Playlist manager is still in the tools menu, though. (The folder is gone from /mods/, I assume that's the result of delete.)
Bug: Doing "check for updates" after all this results in "Internal Error: YR Launch Base has encountered a problem and needs to close. Path not found." (I assume it's checking for updates of Playlist manager, which is physically gone by now.) Clicking OK obviously closes LB.
Restarted Launch Base. Playlist Manager is not under Tools anymore, but not in the list of available tools, either. Check for updates works, but doesn't show playlist manager as before. That leads to the assumption that, to get playlist manager back in the lists, I'd have to install it outside of LB, somehow. No idea how, though. Could check the documentation, but I'm doing this from an average user's point of view, and can't be arsed. Not to mention it should at least be semi-obvious to be usable.
Clicked to uninstall Map packs, was asked if I wanted to do that twice, again. (Answered no.)
Problem/possible Bug: Livelog gives bogus output when checking for updates is cancelled - reports completed/no. of available updates even though the window was closed before the update was performed (might be a background logic/GUI update mismatch, iow maybe it did update, and I just closed it before it displayed that).
Tweak: On opening help, LB's menu gets grayed out as if the box was opened modal - inspection shows this is not the case, LB can be used as normal.
Bug: With opened help in background, the OK button on the disclaimer box is useless -> the box doesn't close. X button works. Closing help while disclaimer is open does not change this.
Follow-up: Even if help is not re-opened, the button stays broken.
Restarting LB.
Follow-up: Disclaimer OK works.
Opening help. Accidently opened about first, then disclaimer, now disclaimer OK button works even with help open.
Tweak: FA2 checkbox for terrain expansion integration looks like it's usable, but it isn't.
Uninstalling LB Creator. Am being told the folder could not be removed, residual files. (Uninstall title is always "Name Uninstall: Uninstalling", btw.)
Problem: LB Creator is still in the tools list, even though it's uninstalled. That may be as wanted, but it's counterintuitive. (Same for Playlist manager earlier.)
LB Mod creator folders are empty, deleting them through explorer. Doing right-click -> delete.
"Error while deleting file or folder - File cannot be deleted: The source file or the source medium cannot be read."
OK does not close LB (it's a shell/explorer error, I think).
Problem: LB Creator is gone from the list, but its description is still being shown on the right. Tabbing away and back to tools does not change this.
Bug/reproduced: Doing check for updates results in path not found IE on "Checking for updates to DELETED", as before. Clicking OK closes LB, as advertised.
Creating bogus folders in /mods/.
Restarting LB.
Bug: Right tab at tools is empty, but shows a "Parameters" edit field. Edit fields has no bounds limitation Big Grin Big Grin Big Grin. Hitting enter after entering a few hundred random chars results in Run-time error '381': Invalid property array index. Hitting OK closes LB.
Tweak: "Parameters" caption is in black on dark background, as opposed to the other, useless captions.
Bug/related: Focussing the tools edit field and then tabbing away from tabs returns the same error, no matter if/what/how much was entered.
Bug: FA2 Folder selection edit field can be edited directly, but inputting a non-path (even a full path ending in a file name) results in Run-time error '52': Bad file name or number. OK -> Close.
Created launcher/liblist.gam in bogus mod directory, with purposefully broken update url. Check for updates with no restart now shows YR Launch Base 0.99.0001 as available, updating that.
Bug: Clicked update, it downloaded, tried to execute: "Either Launch base itself or another installer is already running." LB was closed.
Got a new setup in my folder. Redesignating bogus mod as "plugin", since "mod" didn't make it appear, executing new setup.
Bug/related: Empty setup still possible, but now launches existing version.
Mod Creator and playlist manager are back.
Plugins shows "Penis Master Mod!", so I guess ModType=mod is just invalid.
Bug: Can do "uninstall tool" for both playlist manager and LB Creator, but according to check for updates, they're not installed.
Bug: Suddenly, all folders in the RA2 hierarchy are read-only?! (Wasn't me, wasn't before, so it must be related to LB's activities.)
Bug: Doing "remove plugin" still removes Penis Master Mod from the list, even though I got an "access denied, make sure file is not in use or read-only" error, and the folder is still there.
Closed LB, tried to give read/write access via properties, restarted LB.
Penis Master Mod is back in the list.
Entire tree (Launch Base and all children) is read-only again, no success removing.
Bug/reproduced: According to LB, I just successfully removed playlist manager (still residual files), but it's still in the list, even after tabbing back.
Playlist manager folder could be deleted without problems, furthering my believe the access problems are LB related.
Bug/reproduced: Checking for updates after removing playlist manager again crashes LB.

I'm done for now. Attached is LaunchBase.log, except.txt seems to replace itself on crash, the current entry is
Internal Error
Date: 2007-09-24 22:19:05
Error: 76
Description: Path not found
Subroutine: CheckForUpdates
a previous one was the same, but with an earlier time.

Sorry for the long and stream-of-conscious way this was done, but that was easier than explaining each test scenario from ground up.
Keep in mind that this was not the only stuff I did, I skipped everything that worked.

On a last note, the mod catalogue without an install button is really stupid. You sit there, open it, see all the mods you could have, and think "okay.....and now what? how do I get them?".
Also, the missing remove buttons a very counter-intuitive.

Edit: Just for clarification, I do know all folders in XP are marked "read-only" without it being true or adhered to by XP - but I did not set anything special, and, according to M$, I should be able to delete the folder exactly because Windows ignores this attribute. Yet, I only can delete the folders previously "deleted" in LB. Something is weird with the permissions there, probably a file lock thing or something - something like an earlier instance of LB took ownership of the files and folders, and never released it due to being crashed. Or something.

Attached Files
.log   Less than 1 minute ago">LaunchBase.log (Size: 11.46 KB / Downloads: 566)
Forum Rules

(01.06.2011, 05:43:25)kenosis Wrote: Oh damn don't be disgraced again!

(25.06.2011, 20:42:59)Nighthawk Wrote: The proverbial bearded omni-bug may be dead, but the containment campaign is still being waged in the desert.
Now *that's* a bug report! Big Grin 2

Worth playing: 1 | 2 | 3
I'll say... o_O
well, i only get as far as the first bug and problem, because it doesn't seem to run for me. I'll get marshall more info when i get home.
I'm going to try and address most of what Renegade has reported asap.
Ever wondered what the hell is going on?
Believe me friend you're not the only one.

Check out Launch Base for RA2/YR -
Also home to the Purple Alert mod, 1.002 UMP, and the YR Playlist Manager.
All I get when starting LB is this weird error:
Less than 1 minute ago" />   

I did the steps described by the following page:
(The file already existed)

Then LB started with an Internal error and complained about "MSCOMCTL.OCX".

.txt   Less than 1 minute ago">except.txt (Size: 194 bytes / Downloads: 738)
Again I used my little page:
(This time the file didn't exist)

And after that it worked!

Maybe others will have these problems too.

BUG: After unistalling YR Mappack, it isn't in the list anymore but the info is still shown at the right, Clicking "View Manual" leads to run-time error (of course) and closed the program. After restart the info entry was gone. -> Seems to happen every time the last entry in the list is being deleted.
BUG/RELATED: Checking for updates again, the Mappack wasn't listed.
BUG/RELATED: In the tools menue, after uninstalling everything, it was possible to add parameters. After (!!!) adding some parameters (I used "test"), the "Check for Updates"-Option crashed LB with runtime error '381', "Invalid property array index". (Hah. I'm sure Renegade didn't found this one!)
BUG: Installing the Mappack doesn't work, "Plugin failed to authenticate."
TWEAK: Maybe formatting the help with headlines, it is very uncomfortable to read.
TWEAK: When clicking on "View Change Log for Specific Update" in the Update window, the log file is opened with notepad - which doesn't recognize the line feeds. (There's a kind of this symbol instead of a new line []).
[Image: osen2o7mpmm4jg1fs0.jpg]
I think that the mappack isn't listed under check for updates isn't a bug per se...I think it checks for updates of installed software, and you just deinstalled the map pack. But I do agree it's a little counterintuitive - I think Check for Updates and the Mod Catalogue should be combined to one online repository system, like the ones for apt-get, yum or yast.
Forum Rules

(01.06.2011, 05:43:25)kenosis Wrote: Oh damn don't be disgraced again!

(25.06.2011, 20:42:59)Nighthawk Wrote: The proverbial bearded omni-bug may be dead, but the containment campaign is still being waged in the desert.
You're right. So it seems that there is no way to reinstall Mappack again...
[Image: osen2o7mpmm4jg1fs0.jpg]
As Renegade has suggested, the whole concept of "catalogue mods" is confusing and not very helpful. I am in the process of removing them and making the "Mod Catalogue" much more like the Check For Updates facility.

I have already fixed many of the other bugs that have been mentioned (as well as some that haven't been noticed) and am also adding a verbose logging option so that I can track down the cause of Bobingabout's error.

I want to try and address everything that has been reported before releasing the next update. Hopefully within a couple of days...
Ever wondered what the hell is going on?
Believe me friend you're not the only one.

Check out Launch Base for RA2/YR -
Also home to the Purple Alert mod, 1.002 UMP, and the YR Playlist Manager.
lol, my laptop is a bastard, lol.
I have made some progress although there are still a few things to be addressed.

You can download version 0.99.0002 from the same url as before. I reccomend that you clean install the new version. I already know about three new problems arrising from the work I have been doing these last few days, but I have to be up early for work so cannot do any more now.
1. Browse Mod Catalogue will almost certainly crash.
2. YR Map Packs plugin still does not authenticate (as a result of the new uninstall settings).
3. New uninstall method works okay (at least for me) but was incredibly slow. May just be my crappy system.

Here is the change log for this version:
Version 0.99.0002 [2007-09-30]
Setup Program:
YR Launch Base component in setup program is now compulsory and invisible.
Enable LiveLog component in setup program will no longer set LiveLogDelay to 500. Default is zero.
Check For Updates:
Fixed bug with Check For Updates where if there was not enough disk space to download an update, several controls would disappear.
Log output no longer claims update check was successful if the user cancels the update check.
Update check will no longer crash after a mod has been uninstalled/deleted via the right-click menu.
When a download is complete, a message box will now be displayed warning you that Launch Base will close so that the downloaded mod can be installed. OK and Cancel buttons.
Clicking the X of the Check For Updates window during an update check or download will properly cancel any file download in progress.
Mod Catalogue:
"Catalogue Mods" removed. These were confusing and of little benefit.
Mod Catalogue is now more like the Check For Updates facility.
Fixed crash that occurred if you clicked on the X of the disclaimer window during initialisation.
Clicking the X of the disclaimer window will no longer make the OK button inoperable.
Cut disclaimer message down so that it is a bit less waffly.
Visual fixes/enhancements:
The 'Integrate Terrain Expansion' checkbox is now only visible when it is enabled.
The 'Install Plugin' button is no longer a plain grey button if the available plugins list is empty.
If a tab has no plugins/tools listed, then the stock banner image will be displayed instead of a plain grey box.
Added icons to all message boxes.
Corrected/improved some message box/log file messages.
The color of the 'Parameters' label on the Tools menu will now change with the selected skin.
The Tools' 'Parameters' text box is no longer visible when the Tools list is empty. This also prevents a crash when the textbox loses focus when no tool was selected.
Uninstall/Delete issues:
Fixed bug where uninstalling/deleting a user tool via the right-click menu did not remove redundant Tools menu entries.
Mods uninstalled/deleted via the right-click menu will no longer leave their details on display.
Launch Base will now handle mod removals itself rather than relying on third party uninstall programs.
Added new option: Verbose Log. This outputs extra logging information for debug purposes.
RockPatch Logging now defaults to off if the setting has not been changed in Tools > Options.
Miscellaneous fixes/changes:
The Tools' 'Parameters' text box now has a maximum character limit of 255. This was the maximum length of text that can actually be saved.
If there is not enough disk space to install a mod then installation will be aborted, rather than Launch Base shutting down.
Restore process would always restore residual files even if persistant mods was turned on. This could have caused mod corruption, errors and crashes.
Reorganised the way residual files are handled during launch/uninstall of a mod.
<userdata.lbu> (thus far only used to store Tool parameters) is now stored in the launcher folder.
Update Notes:
You should manually delete all "catalogue mods" from LaunchBase/mods as these are no longer valid.
You should manually move any <userdata.lbu> files to the owning mod's launcher folder.
Do not run mod installers created with Launch Base Mod Creator 0.99.
Users of Launch Base Mod Creator should update it to version 0.99.0002.

Launch Base Mod Creator:
Version 0.99.0002 [2007-09-30]
When loading an <.lbp>, the version number would be set based on today's date, even if the Automatic version checkbox was not ticked.
Removed 'Catalogue Mod' checkbox, as this feature no longer exists in Launch Base.
Installers no longer generate an uninstall program.
The generated <liblist.gam> file now contains the uninstall information that Launch Base needs to remove mods.
When creating your installer, any reserved files/folders in the 'Include Program Directory' will not be included, and a warning message will be displayed.
Added icons to all message boxes.
Minor updates to help files.

Things that have been mentioned but not explored in detail yet:
I have added some verbose logging to try and track down Bobingabout's error, but haven't added anywhere near enough yet.

Setup programs downloaded via Check For Updates and Mod Catalogue that are then not installed are stored in a 'setups' directory. However, Launch Base doesn't know they are available so will just try to download them again - I have plans to correct this.

Renegade got a "Run-time error '52': Bad file name or number." when entering a non-existant path in the FA2 folder text box. I have tried this on my ME machine at home and on XP at work and couldn't replicate it. However this did used to happen on my work XP machine before I fixed it. Might be particular version of a VB component installed on Renegade's machine - I need to investigate this further.

LB Setup program should provide an uninstaller and add an entry to Add/Remove programs. I'll do this at some point.

Renegade got the message "Either Launch base itself or another installer is already running." after LB was closed. This might be an issue with LB crashing and leaving a mutex open, although I haven't been able to replicate it yet.

Renegade's read/write access errors and folders going read-only. I'm stumped on this one. I need to research this on the net a bit more and do some more testing on XP.

I am planning on building a new PC soon and will install XP so hopefully will find it easier replicating XP-specific problems.

gordon-creAtive had issues with certain OCX files not being registered. I should be able to make some sort of improvements to the installer to include OCX files that might be missing.

I think that covers everything that has been discussed so far. If I've missed anything then please let me know.
Ever wondered what the hell is going on?
Believe me friend you're not the only one.

Check out Launch Base for RA2/YR -
Also home to the Purple Alert mod, 1.002 UMP, and the YR Playlist Manager.
Ha first one!

NOTE: I tried to replicate Ren's FA2 command-line bug, I just said "Could not detect FA2 in folder", even with non existant drive letters.

BUG: After checking for updates, the "Back to main Launch Menu" Button did nothing (even right mouse button-> close on the taskbar didn't work. But LB didn't crashed, he just ignored everything). Always happened. Additionally, LB didn't found any updates (I guess that's wanted)

KNOWN BUG: Mod catalogue always crahsed on opening. Unhappy Wanna test that plugin stuff.

MAYBE BUG: I used the previous beta to get the plugins, and it telled me that the YRMappack version is 1..5 - I guess that's a 'server' problem and should be 1.5 ?!?

TWEAK: During 'playing' YR, I switched to win with Alt-Tab and LB completly hang. Maybe it's not necessary but disabling all buttons during play would look better...

That's all for now, because I'm unable to test other stuff, I can't download anything...
[Image: osen2o7mpmm4jg1fs0.jpg]
Version 0.99.0003 [2007-10-01]
'Back to Launch Menu' button in Check For Updates window is no longer inoperable.
Mod Catalogue will no longer crash.
When the Mod Catalogue window is open, the main Launch Base window will be hidden.
Minor updates to help files.

You should be able to download the new version via the 0.99.0002 Check For Updates facility.

gordon-creAtive Wrote:MAYBE BUG: I used the previous beta to get the plugins, and it telled me that the YRMappack version is 1..5 - I guess that's a 'server' problem and should be 1.5 ?!?
Not a bug, shows how version can be [ab]used. It's supposed to mean "1 to 5" as there are 5 map packs included. Internally, this version number translates to "1.0.5".

gordon-creAtive Wrote:TWEAK: During 'playing' YR, I switched to win with Alt-Tab and LB completly hang. Maybe it's not necessary but disabling all buttons during play would look better...
Not sure what I can do about this. Launch Base is frozen because it is waiting for the game to finish. As soon as the game finishes it has to perform some operations (which might include deactivating the mod). Just like XCC Mod Launcher. If we continually refresh the window while waiting for the game to finish then this will use up system resources.

Some things that Renegade said before that I just realised I hadn't responded to:
Renegade Wrote:Problem: There is no obvious uninstall button.
I plan to add an uninstaller for Launch Base itself but I assume you are referring to the mods.
Hadn't planned on their being an obvious uninstall button for mods as it would be used infrequently and I didn't want to waste space on the main form.
The right-click menu was really just an after-thought. It's documented in the help files but I expect most users thinking 'I want to get rid of this mod' will just go and delete it manually.
This could be better documented. Not sure where I would put a button...

Renegade Wrote:Tweak: On opening help, LB's menu gets grayed out as if the box was opened modal...
Not sure how to change this. but also not sure why this is a problem. For example, Notepad behaves in the same way with its help topics.
Not sure how this is controlled, or even if I can control it with VB.

Quote:Problem: After doing right-click -> uninstall, I can now do right-click -> delete.
This is because the uninstall.exe program got removed. Launch Base could still try to delete the residual files though. This is tied into the other issues with uninstall, most of which should now be resolved with the new removal system (although I imagine that there are still access issues which I need to investigate - reports from other users' experience with this would be helpful).
Ever wondered what the hell is going on?
Believe me friend you're not the only one.

Check out Launch Base for RA2/YR -
Also home to the Purple Alert mod, 1.002 UMP, and the YR Playlist Manager.
Oh no. Launching LB Mod Creator lead to "Component TABCTL32.OCX or one of it's components or one of it's depencies not correctly registed". I guess that's the same problem like before with LB, I'll check it after school.

TWEAK: The Playlist Manager appears in the tools menu, but the LB Mod Creator does not (both tools are listed in the tools tab)

BUG: Could not install YR mappack (-> Install Plugin Button) "Failed to read checksum from file [C&CFolder]\LaunchBase\Mods\yrmaps\launcher.liblist.gam". This message was repeated for a bunch of files *klickklickklickklickklickklickklickklickklickklickklickklick*

So far for now
[Image: osen2o7mpmm4jg1fs0.jpg]

Users browsing this thread: 1 Guest(s)