Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AI Editor
#1
Yeah, I have downloaded your (DCoder) AI editor (the lastest edition) from here
but when I download it and try to run it, a popup comes up saying that "Window's is unable to open the program" Do you have any idea of what I should do?
Reply
#2
Do you have WinRAR?

Worth playing: 1 | 2 | 3
Reply
#3
Ah, I have it working now. The problem was that I didn't have WinRAR. Thanks for the help DCoder. But now I've encountered another problem :S

When I edit the AI I change the Taskforces and then click the save button. I then save the changes again (from the save button on the menu) but for some reason the AI does not use my new changes. Any idea with what's wrong, or am I doing something wrong?
Reply
#4
saving in the wrong place?
changing the filename?
maybe they just havn't tried building that taskforce yet.
Reply
#5
Perhaps they haven't...I'll play a few more games just to test it out.

I think my file is being saved in the right place (the RA2 directory, where I have extracted the AI.ini to).
Reply
#6
Did you make a trigger, scripttype and teamtype to deal with the taskforce?
Ares Project Manager.
[Image: t3wbanner.png]
[Image: cncgsigsb_sml.png]
Open Ares positions: Documentation Maintainer, Active Testers.
PM if interested.
Reply
#7
Well, no. I haven't actually added any Taskforces. I'm just editing the existing ones and making them harder.
Reply
#8
Try editing one of the basic taskforces, like [0A37731C-G] or [0ACDC72C-G], the AI uses them very frequently, so you should see easily if your changes take effect. If they don't, attach the edited file here.

Worth playing: 1 | 2 | 3
Reply
#9
thats 1 reason why i said "maybe they just havn't tried building that taskforce yet." i phased it that way to signify that they might build it, but its just got a low probablility of them doing it.
Reply
#10
DCoder Wrote:Try editing one of the basic taskforces, like [0A37731C-G] or [0ACDC72C-G], the AI uses them very frequently, so you should see easily if your changes take effect. If they don't, attach the edited file here.

I have already edited them, and they still don't show up! The AI uses the old unedited version of attack. I have attached the ai.ini

Thanks for the help so farWink


Attached Files
.ini   Less than 1 minute ago">ai.ini.ini (Size: 84.7 KB / Downloads: 465)
Reply
#11
... wow. -50 points for Windows.
Look at the filename of what you just attached, Windows tricked you.

Control Panel > Folder Options > View > uncheck "hide known file extensions". That should fix this, and I will try to find a programmatical way around this for INI E V2.

Worth playing: 1 | 2 | 3
Reply
#12
Well I did what you said and I could not find the "hide known file extensions"

I'll post a picture in a second...


EDIT: Here is a picture of my control panel to view. It doesn't have what you said on it, unless it was "Hide Extensions for known file types" in which case then that is not the problem as I have already unchecked it and tried it out, and it still did not work...


Attached Files Thumbnail(s)
Less than 1 minute ago" />   
Reply
#13
That option itself is not the problem ¬_¬
The problem is that it hides the file extension, rendering "aimd.ini" only as "aimd", and then either you or the program added an ".ini" to it - but the original ".ini" was only hidden, so now your file is named "aimd.ini.ini" - which is the wrong filename.

Turning that option off helps you notice this in the future. If it is on, remove the ".ini" from the filename. If it is off, remove one of the two ".ini"s you should see.
Forum Rules

(01.06.2011, 05:43:25)kenosis Wrote: Oh damn don't be disgraced again!

(25.06.2011, 20:42:59)Nighthawk Wrote: The proverbial bearded omni-bug may be dead, but the containment campaign is still being waged in the desert.
Reply




Users browsing this thread: 1 Guest(s)