Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
List Index Out Of bounds (-1) - AI Editor
Everytime I press the save button on trigger types, script types, team types and task forces I get "List Index Out Of Bounds (-1)" even if I simply changed something (Like make a taskforce have 6 tanks instead of 4)

Whatever I made/Changed is not saved but the programme continues running. But as the changes are not saved it means it is impossible to edit the AI at all useing this program...

I'm pretty sure other people have this program working so I was wondering what the solution to this problem is.
It would be much easier to debug if I could see your AI/Rules file.

Worth playing: 1 | 2 | 3
out of intrest. I only just tried this as I was wanting to rebuild the AI completly but when I try to load a completly unedited Ai.ini and rules.ini from TS 2.03 it gives that error as soon as it starts to load the ai.ini

Attached Files
.ini   Less than 1 minute ago">AI.ini (Size: 1 004 bytes / Downloads: 477)
.ini   Less than 1 minute ago">Rules.ini (Size: 294.39 KB / Downloads: 481)
I cannot reproduce that with neither default TS ini set nor with the files you provided, but I did notice that the TeamTypes list and the actual TeamType have differing IDs (0=832C790-G and [0832C790-G]), which might be causing a problem at your end.
I do know there are quite a few places in my code where that error might be lurking, but I never got around to cleaning it up.

Worth playing: 1 | 2 | 3
well i'll try it on another computer as in that case it may be your program simply doen't like my system.
Nope still getting the same error.
All my comps are running Win XP SP2. I'm not sure which OS your on so it might be a compatibilerty issue there?

Users browsing this thread: 1 Guest(s)