Renegade Projects Network Forums
Cannot start Ares patched YR - Printable Version

+- Renegade Projects Network Forums (
+-- Forum: Inject the Battlefield (
+--- Forum: Ares General Discussion (
+--- Thread: Cannot start Ares patched YR (/showthread.php?tid=1714)

Pages: 1 2

Cannot start Ares patched YR - eva-251 - 09.11.2010

I click my Syringe shortcut with target "C:\Westwood\RA2\Syringe.exe "gamemd.exe" -LOG -nologo" or execute the RunAres.bat file. According to Windows Task Manager, gamemd.exe pops up for about 3-4 seconds and promptly disappears. It consumes either 5888 or 5896 KB of memory in the brief time it runs.

This just started happening recently- I ran YR w/Ares without issue about 2-3 weeks ago. There has been no change in my mods, game installation or version of Ares (until today, when I updated to the 858 revision)

I uploaded the syringe.log, but besides that, I don't know of anything else I can provide to help those that can assess the situation, besides OS and anti-virus-
Windows 7 64bit
Comodo Internet Security Premium- which is of particular relevance, as I may have still had McAfee (free trial) when I last ran YR w/Ares.

edit: I checked Event Viewer, and got two relevant entries:
Quote:Fault bucket 2173749302, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: gamemd.exe
P3: 3bdf544e
P4: StackHash_f3f6
P6: 00000000
P7: c0000005
P8: 52a4c3fd

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: f952d545-ebb3-11df-ad82-c80aa998cd18
Report Status: 0
Quote:Faulting application name: gamemd.exe, version:, time stamp: 0x3bdf544e
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x52a4c3fd
Faulting process id: 0x1d00
Faulting application start time: 0x01cb7fc0bb740670
Faulting application path: C:\Westwood\RA2\gamemd.exe
Faulting module path: unknown
Report Id: f952d545-ebb3-11df-ad82-c80aa998cd18

RE: Cannot start Ares patched YR - DCoder - 09.11.2010

I have W7 x64 myself, and it works fine... did you change the path to YR or something? Have you tried turning off Desktop Composition for gamemd.exe?

RE: Cannot start Ares patched YR - eva-251 - 09.11.2010

Desktop composition just changes the interface to the Windows 7 Basic theme during the brief seconds gamemd.exe runs. What path do you mean exactly? I have no issues running regular Yuri's Revenge using RA2MD.EXE, if that helps.

gamemd.exe = Windows 98 compat; run with admin priv; disable desktop comp

RE: Cannot start Ares patched YR - DCoder - 09.11.2010

I meant the path to gamemd.exe - if you were running a c:\games\yr\gamemd.exe and moved to g:\yr\gamemd.exe, compatibility settings wouldn't carry over, I got slapped by this limitation once so I thought it would be worth checking.

Have you tried setting Syringe.exe to the same compat settings as gamemd.exe?

Does -nologo have any effect? Bink player managed to fuck up multiple times for me until I had desktop composition disabled, who knows how else it might be screwing up.

Does going back to an earlier Ares revision actually help? I'd be very surprised if it did, but you never know Smile

RE: Cannot start Ares patched YR - eva-251 - 09.11.2010

My main Ares shortcuts all have "nologo" and "log". I'll uninstall and reinstall YR later, as disabling Comodo Internet Security had no impact on this issue.

edit- I was running an earlier revision of Ares prior to this, 793, I believe. I upgraded to the newest build because I thought it would solve the issue. I could bounce back to a 454, or even 215 to test that though.

edit2- Running 452, no good.
edit3- after reinstalling RA2, Yuri's Revenge and patching to 1.001, still the same thing.

RE: Cannot start Ares patched YR - Guest - 10.11.2010

It seems that YR in WIN7 didn't need any compatibility, and it can run Ares normally.

RE: Cannot start Ares patched YR - DCoder - 10.11.2010

Well, something had to have changed between when it worked and now... if it wasn't the game itself, it seems like an environment issue - maybe Windows installed some kind of update that fucked things up? I'm really running out of ideas here, sorry.

RE: Cannot start Ares patched YR - eva-251 - 10.11.2010

Well if that was the case, shouldn't everybody with Win7/x64 be suffering from this? This does seem to be related to factors that are external to YR, but if my PC is the only one to suffer from the issue, it should be easily remedied. (uninstall a program, change a setting, etc)

As I said before, this is logged as an application crash in Event Viewer. Are there any files that I can provide to give you or anyone else watching this thread a better idea of what is going on wrong? This issue seems to be quite specific to Yuri's Revenge and Syringe. I run a ton of different games and applications and the only issues now stem from this combo of Syringe, Ares and YR.

@Guest- I noticed that too. But changing compatibility to Win98 improved performance hugely, atleast for me.

RE: Cannot start Ares patched YR - Renegade - 10.11.2010

Do I understand correctly that you have tested running with previously working Ares versions and had the same issue, i.e. you have ruled out a change in Ares as the problem?
I didn't find this in your descriptions: Have you tried running vanilla YR, without Syringe at all? If so, does it run or not?

If it does, that strongly implicates Syringe; if it doesn't, we can rule out our code and focus on a setting or interference with the game engine.

RE: Cannot start Ares patched YR - eva-251 - 10.11.2010

Correct, I have tested 3 revisions of Ares and still encountered the same problem. And I have no issues running Yuri's Revenge stock, IE using RA2MD.exe to start the game. Was able to start it without issue and play 2 Soviet campaign missions before stopping to study for exams.

RE: Cannot start Ares patched YR - Guest - 10.11.2010

>as disabling Comodo Internet Security had no impact on this issue.

Comodo's application also includes kernel protection (called Defense+) and automatic sandboxing of applications, did you disable that too?

If you can't get it running I'll install YR and double check if Comodo Internet Security is to blame.

RE: Cannot start Ares patched YR - eva-251 - 11.11.2010

Yes. Defense+ was the first thing I went to when I checked to see if it was the culprit (as I knew the auto-sandboxing prevented GIMP plug-ins from functioning, figured this could be an issue too).
Made sure everything involved (ra2md, gamemd, ares.dll, syringe.exe, ares.dll.inj) was trusted and not sandbox'd. When that didn't work, I disabled Defense+; when that didn't work, I disabled everything.

Considering the addition of Comodo has been the most significant software change to my PC since I last ran YR w/Ares, I will try uninstalling it some time later tonight or tomorrow, to see if that remedies the problem.

RE: Cannot start Ares patched YR - Renegade - 11.11.2010

Well, given the way Syringe works, that's plausible. A decent anti-virus application should get suspicious when a program starts manipulating another one at runtime...

RE: Cannot start Ares patched YR - eva-251 - 14.11.2010

Uninstalling Comodo fixed it. Reinstalling Comodo started the problems again.

However, I figured out the fix, adding Syringe.exe, Ares.dll and gamemd.exe as exclusions to the Shell-code injection detection code.

Thanks regardless!

RE: Cannot start Ares patched YR - DCoder - 14.11.2010

Thanks for letting us know.. we'll probably have to add something about this problem to the documentation.