Renegade Projects Network Forums

Full Version: Launch Base 0.99.260 vs. Ares
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Well, I have some problems with this.

I can only use the stable version because Launch Base can't see any other branches.

Also if I update Ares manually by copying the files into the Resources folder and starts my mod, LB deletes the files then asks for Ares (because I disallowed it to download the 0.1.710 version).

Actually it was interesting that without Verbose logging even the automated download doesn't worked.

If there is a newer LB version, well my version doesn't know about that.
If you are a registered Ares tester then you should have been given instructions on how to enable access to the other Ares branches - information can be found in the Ares developer forum.

Launch Base does not allow Ares' files to be changed manually.

I'm not sure what you mean by "without Verbose logging even the automated download doesn't worked". The logging should not have any impact on the operation of Launch Base. Can you replicate the problem (i.e. turn off Verbose logging and see if the problem returns)? I suspect you have changed another setting somewhere.
Aaah, this is the problem. Now I understand. Bugreport is the following, then:

Without beta privileges, LaunchBase cannot offer or download a version of Syringe. It detects and offers Ares 0.1 stable, but without Syringe.

And when it starts a mod which requires Ares, it realizes the missing Syringe but gives an error, since it cannot update Syringe thereby can't run Ares.

Syringe v12 should be available without beta privileges, IMO.
Whoa, how did that go unnoticed...

Anyways, fixed now.

Version 0.99.261 released.

Many thanks Graion!
That could be fixed, but this didn't fixed my problems.

I reinstalled LaunchBase and started everything again. After I checked Advanced Mode, I did a Syringe-Ares update and I got constantly Ares update failure. I tried putting 0.1 P1 into the Resources folder manually, but I got verification failures. Then somehow I ended up with revision 666 binary.

The LaunchBase update screen shows that the stable is version 710 (Ares 0.1 P1, isn't it?), although I think the checksums the validation uses are still the 666 versions' one. I think this, because ares.mix passes the verifying, and in the SVN, it's revision is 544, while both the dll and inj has revision number 710.
* DCoder has nothing useful to add, but likes the revision from hell.
Don't edit the Resource folder manually - Launch Base won't like it.

I've released version 0.99.262 - but you'll need to delete any left-over subfolders inside the Resource folder first!
You're gonna hate me...

2010-11-13 15:27:39  Cannot merge "F:\CnC\Red Alert 2\LaunchBase\Resource\yrpm.csf" into ra2md.csf.
2010-11-13 15:27:39  Restoring mod/game configuration.
2010-11-13 15:27:39  Checking for updates to Ares.
2010-11-13 15:27:39  No update available - Ares is up to date. Latest revision: 710
2010-11-13 15:27:39  Ares verification failed.
2010-11-13 15:27:39  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll"
2010-11-13 15:27:40  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll.inj"
2010-11-13 15:27:40  Checking for updates to Ares.
2010-11-13 15:27:40  Ares update available. Latest revision: 710
2010-11-13 15:27:40  Downloading "" to "F:\CnC\Red Alert 2\LaunchBase\Resource\ares.tar.gz"
2010-11-13 15:27:40  Ares update failed - download failed.
2010-11-13 15:27:40  This mod requires the Ares DLL, which is not present.
2010-11-13 15:27:41  Restore process started.

Log attached.
Hmm... I can't replicate that.
Can you delete ares.* from your Resource folder as well as any subfolders and try again?
If that doesn't work, then can you replicate with a clean installation of Launch Base?
Hmmm... after reinstalling LB, it works. Although I had to run the Ares Update twice because it didn't wanted to download Syringe first...

I don't know the problem, currently it's fixed. Thanks.

Forget it!

2010-11-14 18:11:53  DCoder DLL is missing! Unable to extract ra2md.csf from F:\CnC\Red Alert 2\langmd.mix
2010-11-14 18:11:53  Cannot merge "F:\CnC\Red Alert 2\LaunchBase\Resource\yrpm.csf" into ra2md.csf.
2010-11-14 18:11:53  Restoring mod/game configuration.
2010-11-14 18:11:53  Checking for updates to Ares.
2010-11-14 18:11:53  No update available - Ares is up to date. Latest revision: 710
2010-11-14 18:11:53  Ares verification failed.
2010-11-14 18:11:53  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll"
2010-11-14 18:11:53  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll.inj"
2010-11-14 18:11:53  Checking for updates to Ares.
2010-11-14 18:11:53  Ares update available. Latest revision: 710
2010-11-14 18:11:53  Downloading "" to "F:\CnC\Red Alert 2\LaunchBase\Resource\ares.tar.gz"
2010-11-14 18:12:02  Download complete.
2010-11-14 18:12:02  Decompressing F:\CnC\Red Alert 2\LaunchBase\Resource\ares.tar.gz
2010-11-14 18:12:02  Unpacking F:\CnC\Red Alert 2\LaunchBase\Resource\ares.tar
2010-11-14 18:12:02  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\ares.tar"
2010-11-14 18:12:02  Moving "F:\CnC\Red Alert 2\LaunchBase\Resource\binary.r666\Ares.dll" to "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll"
2010-11-14 18:12:02  Moving "F:\CnC\Red Alert 2\LaunchBase\Resource\binary.r666\Ares.dll.inj" to "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll.inj"
2010-11-14 18:12:02  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\ares.mix"
2010-11-14 18:12:02  Moving "F:\CnC\Red Alert 2\LaunchBase\Resource\binary.r666\ares.mix" to "F:\CnC\Red Alert 2\LaunchBase\Resource\ares.mix"
2010-11-14 18:12:02  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\AresDocumentation"
2010-11-14 18:12:02  Moving "F:\CnC\Red Alert 2\LaunchBase\Resource\binary.r666\Documentation" to "F:\CnC\Red Alert 2\LaunchBase\Resource\AresDocumentation"
2010-11-14 18:12:02  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\AresReadme.txt"
2010-11-14 18:12:02  Moving "F:\CnC\Red Alert 2\LaunchBase\Resource\binary.r666\readme.txt" to "F:\CnC\Red Alert 2\LaunchBase\Resource\AresReadme.txt"
2010-11-14 18:12:02  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\binary.r666"
2010-11-14 18:12:02  Ares update complete. Updated to revision 710
2010-11-14 18:12:02  Copying "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll" to "F:\CnC\Red Alert 2\Ares.dll"
2010-11-14 18:12:03  Copying "F:\CnC\Red Alert 2\LaunchBase\Resource\Ares.dll.inj" to "F:\CnC\Red Alert 2\Ares.dll.inj"
2010-11-14 18:12:03  Copying "F:\CnC\Red Alert 2\LaunchBase\Resource\ares.mix" to "F:\CnC\Red Alert 2\ares.mix"
2010-11-14 18:12:03  Mod activated.

It still looks like it wants to use revision 666 instead of revision 710. I even checked by manually downloading Ares 0.1 P1 and both it's Ares.dll and Ares.dll.inj is bigger than what Launch Base has.

Attached screenshot from Total Commander.

Okay, Launch Base is downloading the correct archive, but the archive does not contain the latest version of the DLL.
This is one for Renegade methinks!
OK, I did a workaround by forcing Launch Base that I use a custom Ares dll. (Syringe subfolder in the mod).

And it works... but not flawlessly.

2010-11-14 20:02:11  Restoring mod/game configuration.
2010-11-14 20:02:11  Mod activated.
2010-11-14 20:02:11  Recalculating mod disk usage.
2010-11-14 20:02:11  Checking for updates to Syringe branch "syringe".
2010-11-14 20:02:11  No update available - Syringe is up to date. Latest revision: 12
2010-11-14 20:02:11  Syringe verification failed.
2010-11-14 20:02:11  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\Syringe.exe"
2010-11-14 20:02:11  Checking for updates to Syringe branch "syringe".
2010-11-14 20:02:11  Syringe update available. Latest revision: 12
2010-11-14 20:02:11  Downloading "" to "F:\CnC\Red Alert 2\LaunchBase\Resource\syringe.tar.gz"
2010-11-14 20:02:12  Download complete.
2010-11-14 20:02:12  Decompressing F:\CnC\Red Alert 2\LaunchBase\Resource\syringe.tar.gz
2010-11-14 20:02:12  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\syringe.tar"
2010-11-14 20:02:12  Moving "F:\CnC\Red Alert 2\LaunchBase\Resource\msvc.r12\Syringe.exe" to "F:\CnC\Red Alert 2\LaunchBase\Resource\Syringe.exe"
2010-11-14 20:02:12  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\Syringe.txt"
2010-11-14 20:02:12  Moving "F:\CnC\Red Alert 2\LaunchBase\Resource\msvc.r12\license.txt" to "F:\CnC\Red Alert 2\LaunchBase\Resource\Syringe.txt"
2010-11-14 20:02:12  Syringe update complete. Updated to revision 12
2010-11-14 20:02:12  Deleting "F:\CnC\Red Alert 2\LaunchBase\Resource\msvc.r12"
2010-11-14 20:02:12  Launching Yuri's Revenge via Syringe.

I don't get this... how LaunchBase verificates, actually?
DLL version should be fixed. Probably a timing issue with the last update. I'm more concerned about the fact that no one reported this before.
Maybe nobody else uses LaunchBase with stable Ares.

But the verification thing still applies. When LaunchBase verificates Ares or Syringe if the mod uses it's own version of Ares, it will fails and the selected will be redownloaded.

Downloading failures are because my internet connection isn't that fast, I realize, so that's not a problem.
Quote:I'm more concerned about the fact that no one reported this before.
I don't use LaunchBase with Ares (at least, not yet), otherwise I'd probably have noticed something. As Graion Dilach says, maybe LaunchBase just isn't widely used with the stable builds yet. If it was affecting the unstable builds, surely some of the testers would have noticed by now.
Pages: 1 2 3